conectar 2 switch catalist 3560 mediante fibra

Hola a todos,
muchas gracias por vuestro tiempo. Estoy intentando conectar 2 switch cisco mediante fibra. Tengo una red montada que funciona perfectamente, y ahora necesito añadir un switch más(switch B). El caso es que tengo el mismo modúlo de fibra a la misma velocidad en ambos switch. Le he dado un ranto de ip dentro de mi dominio al switch B pero no consigo que tenga Internet. En la interfaz web del swtich A me parece como “desactivado” el puerto donde conecto la fibra que engancha con el B.
¿alguien puede orientarme?
Muchas gracias!
hace 2 años, 9 meses
Buenas,
Perdona la tardanza, estuve fuera el finde.
Volviendo a tu pregunta, no sabia que tenía que configurar los puertos de manera especial. Imagino a que te refieres a que debo configurar los puertos donde conecto la fibra en ambos switch por CLI? ¿Qué es CLI?
Muchas gracias, quizá sean preguntas estúpidas, lo siento.
SAludos.
hace 2 años, 9 meses
Si, los tenes que configurar como trunk, con su encapsulamiento y las Vlans que estés usando.
Los switchs Cisco verdaderos (no los linksys by cisco) se configuran mediante interface de comando (CLI significa Command Linte Interface) y para eso, necesitas acceder a los switchs mediante el puerto de consola, con el cable correspondiente y configurar los puertos como Trunks, para lo cual, necesitas saber como se hace (podes buscar en google como configurar un puerto como trunk en un switch Cisco).
Saludos.
hace 2 años, 9 meses
Estupendo, muchas gracias. Lo he configurado, pero el segundo siwtch (que se va a añadir a la primera red) lo he configurado reseteandolo y mediante cable ethernet. ¿Es necesario hacerlo como tu me comentas?
Saludos.
hace 2 años, 9 meses
Pues el switch 1 estaba ya configurado y funcionando, ahora necesito conectar otro switch a ese mediante la fibra. Yo pensaba que conectándome a la ip por defecto (10.0.0.1) podía configurarlo.
Saludos.———- Mensaje agregado a las 18:37 ———- Mensaje anterior a las 18:30 ———-Pues el switch 1 estaba ya configurado y funcionando, ahora necesito conectar otro switch a ese mediante la fibra. Yo pensaba que conectándome a la ip por defecto (10.0.0.1) podía configurar directamente el puerto con cable ethernet.
Saludos.
hace 2 años, 9 meses
Bueno, si es un 3560-E si tiene IP por defecto y te deberías poder conectar (los otros switchs cisco por lo general no vienen configurados).
hace 2 años, 9 meses
Imagino que debe ser algo de eso, porque si me meto en la interfaz gráfica del switch1 (el que ya está configurado) y miro los puertos donde conecto la fibra, pone que está deshabilitado. Voy a investigar sobre los cli que me comentas y te comento.
Gracias por tu ayuda!
hace 2 años, 9 meses
pero tenes encendido el led de link?
cuantas vlans tenes? el switch A rutea o tenes otro dispositivo que rutea?
pega la configuración de ambos switch aca y un esquema de entre que puertos los interconectaste y te podemos ayudar mas.
hace 2 años, 9 meses
Hola Martin,
La configuraicón es la siquiente. Tengo un switch Cisco Catalist 3560 (switch A)dentro de un red de oficina, ahora quiero conectar otro switch Catalist 3560(B) en una oficina anexa. El switch A está configurado ya para trabajar con otros switch y elementos dentro de la red el switch B viene de fabrica.
Contestando a tu pregunta, no, cuando conecto la fibra no se enciende el led del puerto donde conecto la fibra. He configurado la ip del switch del mismo modo que el resto de switch de mi red, pero no enciende. No se si debo configurar ambos puertos de manera especial (donde conecto la fibra en el switch A y en el B). He de comentar, que cuando conecto ambos switch mediante fibra, y accedo al acceso web del swith A, dicho puerto aparece amarillo en la interfaz, y pone que no es conocido. Pero no se que hacer.
Muchas gracias a todos por vuestro interés.
hace 2 años, 9 meses
eso es la topologia a nivel fisico.
lo que te pedia es que pegues las capturas de pantalla del menu de configuración.
una pregunta, inveriste la polaridad, rx/tx?
hace 2 años, 9 meses
Buenas,
tenía ententido que siempre van en sentido inverso los conectores de los cables de los módulos. De todas formas he probado invirtiendo los conectores pero tampoco funciona.
Lo siento pero al tratar de un módulo de empresa no puedo poner ninguna configuración en internet. Disculpa las molestias. Pero la configuración es la misma que lós demas switch.
graicas y un vez mas disculpa.
hace 2 años, 9 meses
Hacele un No Shutdown a los puertos de fibra de ambos switchs desde el CLI. Fijate si ambos estan en modo trunk. Si no funciona y no podes poner las configuraciones de las interfaces, vas a tener que contratar a un tecnico con experiencia en Cisco.
hace 2 años, 9 meses
Mira, como te dijo DJ, sin esa información, al menos yo no te puedo ayudar.
como tenes configurado el puerto del switch A? access o trunk? que vlans tenes configuradas? quien configura esto?
como accedes a la administracion de este switch b?
para ser tan reservado con la configuración, supongo que a alguien que sabe de esto podes recurrir.
hace 2 años, 9 meses
Creo que he localizado el problema. Este está en la ip del nuevo switch (B). Todos los switch están en la 192.168.1.2, 1.3…., le pongo la ip 1. X, pero no consigo conectar como con los otros switch. Tiene puesto la mista puerta de enlace etc. El procedimiento que sigo es el siguiente. Reinicio el switch, me conecto a el mediante ethernet al 10.0.0.1. Cambio a modo trunk donde conecto la fibra. Cambio la ip a la 192.168.1.X y la puerta de enlace.
Actualizo e intento acceder. Pero no funciona. Una vez que cambio la ip no puedo acceder por web interfaz ni putty.
Esta es la configuración actual de los puertos donde conecto la fibra en el switch A.
interface GigabitEthernet0/49
description Connection to Switch 1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/50
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/51
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/52
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
ip address 192.168.1.3 255.255.255.0
!
interface Vlan2
no ip address
ip helper-address 192.168.2.4
!
interface Vlan3
no ip address
ip helper-address 192.168.2.4
!
interface Vlan5
no ip address
ip helper-address 192.168.2.4
!
interface Vlan7
ip address 172.16.50.252 255.255.255.0
!
interface Vlan10
no ip address
ip helper-address 192.168.2.4
!
interface Vlan99
no ip address
!
hace 2 años, 9 meses
La verdad que pensaba que con el trunk lo asignaba automáticamente. Pero gracias a ti., me he dado cuenta de que el puerto 49 no está asignado a nada (si le hago un show vlan no me aparece el puerto, y esto me ha dejado loco), sin embargo, este es el puerto que está dando cobertura al switch A (que es el que funciona). Es decir, el puerto 49 del swich, es el canal de fibra que le proporciona internet.
En ambos switch (A y B), he asignado la interfaz donde he conectado la fibra a la vlan donde funcionan todos los equipos, pero entonces me aparcecían los puertos donde conecto la fibra deshabilitado.
#sho interfaces status err-disabled
Port Name Status Reason
Gi0/2 err-disabled gbic-invalid
Gi0/3 err-disabled gbic-invalid
Supuestamente se soluciona con:
no errdisable detect cause gbic-invalid
service unsupported-transceiver
Tras introducir los comandos, en la interfaz web no me aperece el puerto como deshabilitado o desconocido, pero me dice que no he contectado nada. Si hago un #sh interfaces gi0/2, me dice que no tiene nada conectado.
Gracias.
hace 2 años, 9 meses
en realidad, si no pones el commando “switchport allowed vlan 1,2,3,x,z,y”
permitis que todas las vlans pasen por ese trunk.
igual, el problema es que no tenemos la configuracuon del switch b.
tenes configurado vtp?
tipea estos comandos en ambos switches (supongo que en ambos lados estas usando el puerto gi0/49
sh int gi0/49 trunk
sh int gi0/49 switchport
sh run int gi0/49
sh vlan
sh vtp status
hace 2 años, 9 meses
Buenas a todos!, por fin lo he solucionado. Opte por un cambio de estrategia, ya que lo necesitaba operativo. Conecté ambos switch por ethernet en vez de por fibra, y me seguía aparciendo el puerto “desconocido”. Así que cogí el switch a, y descpues de comprobar varias cosas, deshabilité el spaning tree, puse ambos en modo trunk, y poco mas, y nada, ya funciona.
Creo que el problema estaba, en que los modúlos de fibra debían ser cisco, al igual que los switch (cosa que leí después). Yo pensaba que debían ser compatible con la fibra e iguales en ambos extremos unicamente. No lo tengo confirmado, pero la verdad que no conseguí que funcionase con la fibra, por lo que puede que sea verdad.
Bueno, pues tema resuelto, muchas gracias a todos por ir ayudándome a mejorar y encontrar el error entre todos.
hace 2 años, 9 meses
no hace falta que sean cisco. con que sean compatibles alcanza.
si me decis que son sfp+ o xenpak, seria distinto (bah, los sfp+ genericos van como piña).
igual, nunca pense que no se encendia el led del puerto por mal transceiver. que bueno que lo resolviste.
hace 2 años, 9 meses
martinm
no hace falta que sean cisco. con que sean compatibles alcanza.
si me decis que son sfp+ o xenpak, seria distinto (bah, los sfp+ genericos van como piña).
igual, nunca pense que no se encendia el led del puerto por mal transceiver. que bueno que lo resolviste.
Mira vos, no sabia! Siempre use los originales. Gracias por la info!
Saludos.
hace 2 años, 9 meses
 

Buscar mensajes